Skip to main content Text-only Version

myUFL Software Upgrade Takes Place This Month

Grady logo

To keep myUFL current, a software upgrade is being performed this month.  Users should not be significantly impacted, because this upgrade affects some underlying features of the system—not how we complete transactions.

The upgrade to myUFL will begin affecting system users on February 19, if your browser if not compatible with the new browser requirements. Upgrading your browsers before February 19, if needed, is critical to ensure that you will be able to use myUFL after the software upgrade.

Browsers that won’t work with the myUFL software upgrade:

  • Internet Explorer 6
  • Firefox 3.5, 4, 5, and 6

Browsers that will work with the myUFL software upgrade:

  • Internet Explorer 7, 8, and 9*
  • Firefox 3.6 and 7

*Internet Explorer 9 will only be a supported browser after the software upgrade on February 19. Upgrading to Internet Explorer 9 before February 19 will impact your ability to use myUFL.

For additional information about supported browsers and settings that will work with the upgraded myUFL portal, please visit: https://wiki.helpdesk.ufl.edu/FAQs/MyUFLBrowserRequirements

All myUFL users will need to clear their cache and cookies the morning of February 19 before using the system.

Please contact the UF Computing Help Desk at (352) 392-HELP (4357) with any questions you may have.